No more Aegisub until Ubuntu Lucid

Being an otaku who sometimes throw himself headlong into things always to leave them on hold (and perhaps the latter is due to the former), I’m pretty interested in fansubbing and in particular in Aegisub, which got notorious for making sweat one’s guts out in order to get it compiled on non-Windows systems. Concerning this, I found an interesting post from my Aegisub-Ubuntu-pusher, here’s the link (Spanish):

http://gargadonscave.uni.cc/2009/12/no-mas-aegisub-hasta-ubuntu-lucid/

And here’s my personal translation:

No more Aegisub until Ubuntu Lucid

As mentioned in the title of the post, unfortunately I can no more release Aegisub until a late Lucid Lynx (10.04) alpha release comes out. That’s not due to me, but (as I suspected from the beginning) to the old FFMpeg dependencies.

Until recently, I took the old FFMpeg versions and edited ./configure in order to make it compatible with Ubuntu. Now the issue is far beyond. Seemingly the code in the latest versions included in /src/audio-provider* and /src/video-provider*, only works if we compile with FFMpegSource instead of FFMpeg.

This implies that we must compile with FFMpegSource support. But what’s the problem again? FFMpeg dependencies included in Ubuntu Karmic Koala (and therefore in earlier versions too) are so much old that they cannot support it. In other words, without FFMpegSource, “make” will end with errors.

Until recently, Aegisub for Ubuntu didn’t require FFMpegSource. It does now, but in order to upgrade FFMpeg, I must install and compile FFMpeg from his source code. Something I’m not doing, since some programs (like Amarok) would stop playing MP3s.

For our Debian Testing (Squeeze at the moment) fellow who use Debian Multimedia repositories, I just updated my installation tutorial for r3855: http://gargadonscave.uni.cc/2009/11/como-compilar-aegisub-en-debian-y-ubuntu/

To prove you I’m not lying, I’ve been able to compile Aegisub r3855 on Debian, here’s the proof:

[image on the original post]

Ummm… as I can see now, video is not loaded on Debian… Guys, getting back at Ubuntu side, though we are stuck to the r3771 :D

That’s all folks, I feel a bit sorry for making you read a so terrible English.

Italian version

«Che succede?» chiederà qualcuno. In effetti credo sia la prima volta che posto qualcosa in simil-inglese su questo blog, l’idea però mi stuzzicava. D’ora in poi sappiate che ogni volta che vedete un post cominciare in inglese, alla fine ci sono sempre due o tre righe scritte anche in italiano, quindi ignorantoni miei non demoralizzatevi! :D

Riassumo brevemente quanto detto nella prima parte: sono un otaku, non ho vita sociale, sono obeso, brufoloso e anche il mio amico immaginario mi ha abbandonato per andare a guardare i disegni del criceto (cit. Rat-Man). No, è vero tutto solo fino ad otaku, per fortuna. Comunque il punto è: Aegisub è un casino, lo è sempre stato e fino alla 2.1.8 (forse) continuerà ad esserlo. Pertanto incollo anche qui il link a questo interessante post:

http://gargadonscave.uni.cc/2009/12/no-mas-aegisub-hasta-ubuntu-lucid/

E la relativa traduzione, anche se magari essendo italiani qualcosa riuscite a cavarci fuori anche dall’originale:

Niente più Aegisub fino ad Ubuntu Lucid

Come menzionato nel titolo del post, purtroppo non potrò rilasciare Aegisub fino all’uscita di una alpha avanzata di Lucid Lynx (10.04). Questo non a causa mia, ma (come sospettavo fin da subito) per le dipendenze vecchie di FFMpeg.

Fino a poco tempo fa, prendevo le vecchie versioni di FFMpeg e editavo il file ./configure per renderlo compatibile con Ubuntu. Ora però il problema va ben oltre. A quanto pare, il codice incluso in /src/audio-provider* e /src/video-provider* delle ultime versioni, funziona solo si decidiamo di compilare con FFMpegSource e non con FFMpeg.

Questo implica che dobbiamo per forza compilare con supporto a FFMpegSource. Qual è però il problema? Le dipendenze di FFMpeg incluse in Ubuntu Karmic Koala (e quindi nelle versioni precedenti) sono talmente vecchie da non permettere tale supporto. In altre parole, senza FFMpegSource, otterremo dei bei errori lanciando un “make”.

Fino a poco tempo fa, il supporto a FFMpegSource non era necessario in Aegisub per Ubuntu. Ora invece sì, tuttavia per aggiornare la versione di FFMpeg, dovrei installare e compilare FFMpeg dal codice sorgente. Cosa che non farò, dal momento che alcuni programmi (come Amarok) potrebbero smettere di funzionare.

Per i nostri amici di Debian Testing (Squeeze in questo momento) che usano i repository Debian Multimedia, ho aggiornato il tutorial di installazione per la r3855: http://gargadonscave.uni.cc/2009/11/como-compilar-aegisub-en-debian-y-ubuntu/

Per dimostrarvi che non mento, su Debian ho potuto compilare Aegisub r3855, e questa è la prova:

[post originale per l’immagine]

Ummm… da quel che vedo ora, su Debian non apre il video… Ragazzi, torno al fianco di Ubuntu, anche se siamo bloccati alla r3771 :D

PS. Non ditelo agli inglesi, ma non so lo spagnolo.

2 thoughts on “No more Aegisub until Ubuntu Lucid

  1. Gargadon scrive:

    Thanks for the translations. Unfortunately I don’t speak italian, so I can’t check if the translation is correct.

    And the problem is more serious. The Aegisub developers said FFmpeg provider was removed and it won’t exist in any future versions ( http://devel.aegisub.org/ticket/1074 ). FFmpegSource is a great video and audio provider, but it requires FFmpeg headers from 2009 september/october for work. It means if the FFmpeg dependencies included in Ubuntu continue being too old, it will be non possible to compile the newest Aegisub tarballs.

    Best regards.

  2. Shiba scrive:

    Thanks for your reply. I’ve noticed there’s an Aegisub package in a PPA, but as you actually pointed out, right now it’s impossible to have audio/video working in Aegisub under Ubuntu due to the old FFMpeg included in Karmic and, so far, in Lucid. Thank you very much for your support (regarding my blog and specially Ubuntu’s Aegisub), I really appreciate. :)

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...