Conflitti tra VirtualBox e KVM, bastardi…

Se qualcuno di voi, come me, non ha niente di meglio da fare che provare a random nuove distro in emulazione, è probabile che sia incappato in un noioso bug riguardante la virtualizzazione a 64bit e Virtualbox.

Trovandovi davanti a questa schermata, e pensando che fino alla settimana scorsa funzionava tutto senza problemi, molto probabilmente vi verrà istintivo fare l’appello di tutti i santi per una buona mezz’ora e inveire contro la nuova Ubuntu, che, come è noto, è una gran bella margherita. Tuttavia questa volta il problema risiede altrove, e se siete abbastanza fortunati da avere recentemente installato KVM allora la risoluzione è istantanea.

Aprite il terminale e digitate:

$ sudo modprobe -r kvm_amd

Cosa è successo? Semplicemente KVM stava monopolizzando l’accesso a VT-x/AMD-V, indispensabile per virtualizzare sistemi a 64bit (almeno per quello che ne so io). Eseguendo questo comando abbiamo fermato il modulo marrano e possiamo ora usare in tutta tranquillità il nostro VirtualBox.

Attenzione: Questo modulo verrà ricaricato ad ogni avvio del PC, pertanto, se non avete intenzione di disinstallare KVM, per avviare VirtualBox dovrete ogni volta digitare quel comando.

PS: All’inizio scherzavo, s’intende, la virtualizzazione serve soprattutto a gente per lavoro.

Fonte: http://forums.virtualbox.org/viewtopic.php?f=7&t=25262

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...